What’s Vulnerable › Vulnerabilities
CVE-2025-48270: WordPress SKT Blocks plugin <= 2.2 - Cross Site Scripting (XSS) Vulnerability
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-19 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in sonalsinha21 SKT Blocks skt-blocks allows DOM-Based XSS.This issue affects SKT Blocks: from n/a through <= 2.2.
Affected products
- sonalsinha21 SKT Blocks: before 2.3 — fixed in 2.3
How to fix
Upgrade to a fixed version: sonalsinha21 SKT Blocks 2.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-48270 or the next vulnerability affects your stack