What’s Vulnerable › Vulnerabilities
CVE-2025-48371: OpenFGA Authorization Bypass
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-22 · updated 2026-06-17
- Weakness: CWE-285
Description
OpenFGA is an authorization/permission engine. OpenFGA versions 1.8.0 through 1.8.12 (corresponding to Helm chart openfga-0.2.16 through openfga-0.2.30 and docker 1.8.0 through 1.8.12) are vulnerable to authorization bypass when certain Check and ListObject calls are executed. Users are affected under four specific conditions: First, calling Check API or ListObjects with an authorization model that has a relationship directly assignable by both type bound public access and userset; second, there are check or list object queries with contextual tuples for the relationship that can be directly assignable by both type bound public access and userset; third, those contextual tuples’s user field is an userset; and finally, type bound public access tuples are not assigned to the relationship. Users should upgrade to version 1.8.13 to receive a patch. The upgrade is backwards compatible.
Affected products
- openfga Helm Charts: from 0.2.16 before 0.2.32 — fixed in 0.2.32
- openfga: from 1.8.0 before 1.8.13 — fixed in 1.8.13
How to fix
Upgrade to a fixed version: openfga Helm Charts 0.2.32; openfga 1.8.13. Check the vendor advisory for mitigations.
References
- https://github.com/openfga/openfga/commit/e5960d4eba92b723de8ff3a5346a07f50c1379ca
- https://github.com/openfga/openfga/security/advisories/GHSA-c72g-53hw-82q7
Get alerted when CVE-2025-48371 or the next vulnerability affects your stack