What’s Vulnerable › Vulnerabilities
CVE-2025-48377: Dnn.Platform vulnerable to Reflected Cross-Site Scripting (XSS) in module actions in edit mode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-23 · updated 2026-06-17
- Weakness: CWE-79
Description
DNN (formerly DotNetNuke) is an open-source web content management platform (CMS) in the Microsoft ecosystem. Prior to version 9.13.9, a specially crafted URL may be constructed which can inject an XSS payload that is triggered by using some module actions. Version 9.13.9 fixes the issue.
Affected products
- DotNetNuke CMS Fixed in 9.1.1: before 9.13.9 — fixed in 9.13.9
How to fix
Upgrade to a fixed version: DotNetNuke CMS Fixed in 9.1.1 9.13.9. Check the vendor advisory for mitigations.
References
- https://github.com/dnnsoftware/Dnn.Platform/commit/351b166492ad4b6509c273dc83211d52238e31a7
- https://github.com/dnnsoftware/Dnn.Platform/security/advisories/GHSA-79m3-rvx2-3qq9
Get alerted when CVE-2025-48377 or the next vulnerability affects your stack