What’s Vulnerable › Vulnerabilities
CVE-2025-48379: Pillow Vulnerable to Write Buffer Overflow on BCn encoding
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-01 · updated 2026-06-17
- Weakness: CWE-122
Description
Pillow is a Python imaging library. In versions 11.2.0 to before 11.3.0, there is a heap buffer overflow when writing a sufficiently large (>64k encoded with default settings) image in the DDS format due to writing into a buffer without checking for available space. This only affects users who save untrusted data as a compressed DDS image. This issue has been patched in version 11.3.0.
Affected products
- python-pillow Pillow: 11.2.1
References
- https://github.com/python-pillow/Pillow/commit/ef98b3510e3e4f14b547762764813d7e5ca3c5a4
- https://github.com/python-pillow/Pillow/pull/9041
- https://github.com/python-pillow/Pillow/releases/tag/11.3.0
- https://github.com/python-pillow/Pillow/security/advisories/GHSA-xg8h-j46f-w952
Get alerted when CVE-2025-48379 or the next vulnerability affects your stack