What’s Vulnerable › Vulnerabilities
CVE-2025-48384: Git Link Following Vulnerability
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2025-08-25
- EPSS: 4.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-08 · updated 2026-09-24
- Weakness: CWE-59
Description
Git is a fast, scalable, distributed revision control system with an unusually rich command set that provides both high-level operations and full access to internals. When reading a config value, Git strips any trailing carriage return and line feed (CRLF). When writing a config entry, values with a trailing CR are not quoted, causing the CR to be lost when the config is later read. When initializing a submodule, if the submodule path contains a trailing CR, the altered path is read resulting in the submodule being checked out to an incorrect location. If a symlink exists that points the altered path to the submodule hooks directory, and the submodule contains an executable post-checkout hook, the script may be unintentionally executed after checkout. This vulnerability is fixed in v2.43.7, v2.44.4, v2.45.4, v2.46.4, v2.47.3, v2.48.2, v2.49.1, and v2.50.1.
Affected products
- Apple Xcode: before 26.0 — fixed in 26.0
- Debian Linux: 11.0
- git: before 2.43.7; from 2.44.0 before 2.44.4; from 2.45.0 before 2.45.4; from 2.46.0 before 2.46.4; from 2.47.0 before 2.47.3; from 2.48.0 before 2.48.2 — fixed in 2.43.7, 2.44.4, 2.45.4, 2.46.4, 2.47.3, 2.48.2
How to fix
Upgrade to a fixed version: Apple Xcode 26.0; git 2.43.7, 2.44.4, 2.45.4, 2.46.4. Check the vendor advisory for mitigations.
References
- https://github.com/git/git/security/advisories/GHSA-vwqx-4fm8-6qc9
- http://seclists.org/fulldisclosure/2025/Sep/60
- http://www.openwall.com/lists/oss-security/2025/07/08/4
- https://lists.debian.org/debian-lts-announce/2025/10/msg00003.html
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-48384
Get alerted when CVE-2025-48384 or the next vulnerability affects your stack