What’s Vulnerable › Vulnerabilities
CVE-2025-48386: Git allows a buffer overflow in 'wincred' credential helper
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-08 · updated 2026-06-17
- Weakness: CWE-120
Description
Git is a fast, scalable, distributed revision control system with an unusually rich command set that provides both high-level operations and full access to internals. The wincred credential helper uses a static buffer (target) as a unique key for storing and comparing against internal storage. This credential helper does not properly bounds check the available space remaining in the buffer before appending to it with wcsncat(), leading to potential buffer overflows. This vulnerability is fixed in v2.43.7, v2.44.4, v2.45.4, v2.46.4, v2.47.3, v2.48.2, v2.49.1, and v2.50.1.
Affected products
- git: before 2.43.7; from 2.44.0-rc0, < 2.44.4; from 2.45.0-rc0, < 2.45.4; from 2.46.0-rc0, < 2.46.4; from 2.47.0-rc0, < 2.47.3; from 2.48.0-rc0, < 2.48.2
References
- https://github.com/git/git/security/advisories/GHSA-4v56-3xvj-xvfr
- http://www.openwall.com/lists/oss-security/2025/07/08/4
Get alerted when CVE-2025-48386 or the next vulnerability affects your stack