What’s Vulnerable › Vulnerabilities
CVE-2025-48390: FreeScout Vulnerable to Remote Code Execution (RCE)
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-29 · updated 2026-06-17
- Weakness: CWE-94
Description
FreeScout is a free self-hosted help desk and shared mailbox. Prior to version 1.8.178, FreeScout is vulnerable to code injection due to insufficient validation of user input in the php_path parameter. The backticks characters are not removed, as well as tabulation is not removed. When checking user input, the file_exists function is also called to check for the presence of such a file (folder) in the file system. A user with the administrator role can create a translation for the language, which will create a folder in the file system. Further in tools.php, the user can specify the path to this folder as php_path, which will lead to the execution of code in backticks. This issue has been patched in version 1.8.178.
Affected products
- freescout-help-desk freescout: before 1.8.178 — fixed in 1.8.178
How to fix
Upgrade to a fixed version: freescout-help-desk freescout 1.8.178. Check the vendor advisory for mitigations.
References
- https://github.com/freescout-help-desk/freescout/commit/fb33d672a2d67f5a2b3cf69c80945267f17908b2
- https://github.com/freescout-help-desk/freescout/security/advisories/GHSA-5324-cw55-gwj5
Get alerted when CVE-2025-48390 or the next vulnerability affects your stack