What’s Vulnerable › Vulnerabilities
CVE-2025-48393
- Severity: medium (CVSS 5.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-06 · updated 2026-06-17
- Weakness: CWE-295
Description
The server identity check mechanism for firmware upgrade performed via command shell is insecurely implemented potentially allowing an attacker to perform a Man-in-the-middle attack. This security issue has been fixed in the latest firmware version of Eaton G4 PDU which is available on the Eaton download center.
Affected products
- Eaton G4 PDU: before 3.5.0 — fixed in 3.5.0
How to fix
Upgrade to a fixed version: Eaton G4 PDU 3.5.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-48393 or the next vulnerability affects your stack