What’s Vulnerable › Vulnerabilities
CVE-2025-48475: FreeScout Vulnerable to Insufficient Authorization
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-29 · updated 2026-06-17
- Weakness: CWE-863
Description
FreeScout is a free self-hosted help desk and shared mailbox. Prior to version 1.8.180, the System does not provide a check on which "clients" of the System an authorized user can view and edit, and which ones they cannot. As a result, an authorized user who does not have access to any of the existing mailboxes, as well as to any of the existing conversations, has the ability to view and edit the System's clients. The limitation of client visibility can be implemented by the limit_user_customer_visibility setting, however, in the specified scenarios, there is no check for the presence of this setting. This issue has been patched in version 1.8.180.
Affected products
- freescout-help-desk freescout: before 1.8.180 — fixed in 1.8.180
How to fix
Upgrade to a fixed version: freescout-help-desk freescout 1.8.180. Check the vendor advisory for mitigations.
References
- https://github.com/freescout-help-desk/freescout/commit/1f154ce039618ed5abd960c97619c23534c0717a
- https://github.com/freescout-help-desk/freescout/security/advisories/GHSA-xvch-f75c-8w8q
Get alerted when CVE-2025-48475 or the next vulnerability affects your stack