What’s Vulnerable › Vulnerabilities
CVE-2025-48739
- Severity: medium (CVSS 4.6 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-23 · updated 2026-06-17
- Weakness: CWE-918
Description
A Server-Side Request Forgery (SSRF) vulnerability in StrangeBee TheHive 5.2.0 before 5.2.16, 5.3.0 before 5.3.11, 5.4.0 before 5.4.10, and 5.5.0 before 5.5.1 allows remote authenticated attackers with admin permissions (allowing them to access specific API endpoints) to manipulate URLs to direct requests to unexpected hosts or ports. This allows the attacker to use a TheHive server as a proxy to reach internal or otherwise restricted resources. This could be exploited to access other servers on the internal network.
Affected products
- StrangeBee TheHive: from 5.2.0 before 5.2.16; from 5.3.0 before 5.3.11; from 5.4.0 before 5.4.10; from 5.5.0 before 5.5.1 — fixed in 5.2.16, 5.3.11, 5.4.10, 5.5.1
How to fix
Upgrade to a fixed version: StrangeBee TheHive 5.2.16, 5.3.11, 5.4.10, 5.5.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-48739 or the next vulnerability affects your stack