What’s Vulnerable › Vulnerabilities
CVE-2025-48741
- Severity: medium (CVSS 6.8 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-23 · updated 2026-06-17
- Weakness: CWE-266
Description
A Broken Access Control vulnerability in StrangeBee TheHive 5.2.0 before 5.2.16, 5.3.0 before 5.3.11, and 5.4.0 before 5.4.10 allows remote, authenticated, and unprivileged users to retrieve alerts, cases, logs, observables, or tasks, regardless of the user's permissions, through a specific API endpoint.
Affected products
- StrangeBee TheHive: from 5.2.0 before 5.2.16; from 5.3.0 before 5.3.11; from 5.4.0 before 5.4.10 — fixed in 5.2.16, 5.3.11, 5.4.10
How to fix
Upgrade to a fixed version: StrangeBee TheHive 5.2.16, 5.3.11, 5.4.10. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-48741 or the next vulnerability affects your stack