What’s Vulnerable › Vulnerabilities
CVE-2025-48866: ModSecurity has possible DoS vulnerability in sanitiseArg action
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-02 · updated 2026-06-17
- Weakness: CWE-1050
Description
ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. Versions prior to 2.9.10 contain a denial of service vulnerability similar to GHSA-859r-vvv8-rm8r/CVE-2025-47947. The `sanitiseArg` (and `sanitizeArg` - this is the same action but an alias) is vulnerable to adding an excessive number of arguments, thereby leading to denial of service. Version 2.9.10 fixes the issue. As a workaround, avoid using rules that contain the `sanitiseArg` (or `sanitizeArg`) action.
Affected products
- owasp-modsecurity ModSecurity: before 2.9.10 — fixed in 2.9.10
How to fix
Upgrade to a fixed version: owasp-modsecurity ModSecurity 2.9.10. Check the vendor advisory for mitigations.
References
- https://github.com/owasp-modsecurity/ModSecurity/commit/3a54ccea62d3f7151bb08cb78d60c5e90b53ca2e
- https://github.com/owasp-modsecurity/ModSecurity/security/advisories/GHSA-859r-vvv8-rm8r
- https://github.com/owasp-modsecurity/ModSecurity/security/advisories/GHSA-f82j-8pp7-cw2w
- https://github.com/owasp-modsecurity/ModSecurity/wiki/Reference-Manual-(v2.x)#sanitisearg
- https://lists.debian.org/debian-lts-announce/2025/06/msg00009.html
Get alerted when CVE-2025-48866 or the next vulnerability affects your stack