What’s Vulnerable › Vulnerabilities
CVE-2025-48875: FreeScout Vulnerable to Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-30 · updated 2026-06-17
- Weakness: CWE-79
Description
FreeScout is a free self-hosted help desk and shared mailbox. Prior to version 1.8.181, the system's incorrect validation of last_name and first_name during profile data updates allows for the injection of arbitrary JavaScript code, which will be executed in a flesh-message when the data is deleted, potentially leading to a Cross-Site Scripting (XSS) vulnerability. This issue has been patched in version 1.8.181.
Affected products
- freescout-help-desk freescout: before 1.8.181 — fixed in 1.8.181
How to fix
Upgrade to a fixed version: freescout-help-desk freescout 1.8.181. Check the vendor advisory for mitigations.
References
- https://github.com/freescout-help-desk/freescout/commit/508dda16853a39fcb6c2b46ea7b7f442d5f7eda7
- https://github.com/freescout-help-desk/freescout/security/advisories/GHSA-mjjx-rv96-w9hq
Get alerted when CVE-2025-48875 or the next vulnerability affects your stack