What’s Vulnerable › Vulnerabilities
CVE-2025-48883: Chrome PHP is missing encoding in `CssSelector`
- Severity: medium (CVSS 5.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-30 · updated 2026-06-17
- Weakness: CWE-79
Description
Chrome PHP allows users to start playing with chrome/chromium in headless mode from PHP. Prior to version 1.14.0, CSS Selector expressions are not properly encoded, which can lead to XSS (cross-site scripting) vulnerabilities. This is patched in v1.14.0. As a workaround, users can apply encoding manually to their selectors if they are unable to upgrade.
Affected products
- chrome-php chrome: before 1.14.0
References
- https://github.com/chrome-php/chrome/commit/34b2b8d1691f4e3940b1e1e95d388fffe81169c8
- https://github.com/chrome-php/chrome/pull/691
- https://github.com/chrome-php/chrome/security/advisories/GHSA-3432-fmrf-7vmh
Get alerted when CVE-2025-48883 or the next vulnerability affects your stack