What’s Vulnerable › Vulnerabilities
CVE-2025-48887: vLLM has a Regular Expression Denial of Service (ReDoS, Exponential Complexity) Vulnerability in `pythonic_tool_parser.py`
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-30 · updated 2026-06-17
- Weakness: CWE-1333
Description
vLLM, an inference and serving engine for large language models (LLMs), has a Regular Expression Denial of Service (ReDoS) vulnerability in the file `vllm/entrypoints/openai/tool_parsers/pythonic_tool_parser.py` of versions 0.6.4 up to but excluding 0.9.0. The root cause is the use of a highly complex and nested regular expression for tool call detection, which can be exploited by an attacker to cause severe performance degradation or make the service unavailable. The pattern contains multiple nested quantifiers, optional groups, and inner repetitions which make it vulnerable to catastrophic backtracking. Version 0.9.0 contains a patch for the issue.
Affected products
- vllm-project vllm: from 0.6.4 before 0.9.0 — fixed in 0.9.0
How to fix
Upgrade to a fixed version: vllm-project vllm 0.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/vllm-project/vllm/commit/4fc1bf813ad80172c1db31264beaef7d93fe0601
- https://github.com/vllm-project/vllm/pull/18454
- https://github.com/vllm-project/vllm/security/advisories/GHSA-w6q7-j642-7c25
- https://github.com/vllm-project/vllm/security/advisories/GHSA-w6q7-j642-7c25
Get alerted when CVE-2025-48887 or the next vulnerability affects your stack