What’s Vulnerable › Vulnerabilities
CVE-2025-48888: Deno run with --allow-read and --deny-read flags results in allowed
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-04 · updated 2026-06-17
- Weakness: CWE-863
Description
Deno is a JavaScript, TypeScript, and WebAssembly runtime. Starting in version 1.41.3 and prior to versions 2.1.13, 2.2.13, and 2.3.2, `deno run --allow-read --deny-read main.ts` results in allowed, even though 'deny' should be stronger. The result is the same with all global unary permissions given as `--allow-* --deny-*`. This only affects a nonsensical combination of flags, so there shouldn't be a real impact on the userbase. Users may upgrade to version 2.1.13, 2.2.13, or 2.3.2 to receive a patch.
Affected products
- denoland deno: from 1.41.3 before 2.1.13; from 2.2.0 before 2.2.13; from 2.3.0 before 2.3.2 — fixed in 2.1.13, 2.2.13, 2.3.2
How to fix
Upgrade to a fixed version: denoland deno 2.1.13, 2.2.13, 2.3.2. Check the vendor advisory for mitigations.
References
- https://github.com/denoland/deno/commit/2f0fae9d9071dcaf0a689bc7097584b1b9ebc8db
- https://github.com/denoland/deno/commit/9d665572d3cd39f997e29e6daac7c1102fc5c04f
- https://github.com/denoland/deno/commit/ef315b56c26c9ef5f25284a5100d2ed525a148cf
- https://github.com/denoland/deno/pull/22894
- https://github.com/denoland/deno/pull/29213
- https://github.com/denoland/deno/security/advisories/GHSA-xqxc-x6p3-w683
- https://github.com/denoland/deno/security/advisories/GHSA-xqxc-x6p3-w683
Get alerted when CVE-2025-48888 or the next vulnerability affects your stack