What’s Vulnerable › Vulnerabilities
CVE-2025-48912: Apache Superset: Improper authorization bypass on row level security via SQL Injection
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-30 · updated 2026-06-17
- Weakness: CWE-89
Description
An authenticated malicious actor using specially crafted requests could bypass row level security configuration by injecting SQL into 'sqlExpression' fields. This allowed the execution of sub-queries to evade parsing defenses ultimately granting unauthorized access to data. This issue affects Apache Superset: before 4.1.2. Users are recommended to upgrade to version 4.1.2, which fixes the issue.
Affected products
- Apache Superset: before 4.1.2 — fixed in 4.1.2
How to fix
Upgrade to a fixed version: Apache Superset 4.1.2. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/ms2t2oq218hb7l628trsogo4fj7h1135
- http://www.openwall.com/lists/oss-security/2025/05/30/3
Get alerted when CVE-2025-48912 or the next vulnerability affects your stack