What’s Vulnerable › Vulnerabilities
CVE-2025-48913: Apache CXF: Untrusted JMS configuration can lead to RCE
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-08 · updated 2026-06-17
- Weakness: CWE-20
Description
If untrusted users are allowed to configure JMS for Apache CXF, previously they could use RMI or LDAP URLs, potentially leading to code execution capabilities. This interface is now restricted to reject those protocols, removing this possibility. Users are recommended to upgrade to versions 3.6.8, 4.0.9 or 4.1.3, which fix this issue.
Affected products
- Apache Software Foundation Apache CXF: before 3.6.8; from 4.0.0 before 4.0.9; from 4.1.0 before 4.1.3 — fixed in 3.6.8, 4.0.9, 4.1.3
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache CXF 3.6.8, 4.0.9, 4.1.3. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/f1nv488ztc0js4g5ml2v88mzkzslyh83
- http://www.openwall.com/lists/oss-security/2025/08/07/2
Get alerted when CVE-2025-48913 or the next vulnerability affects your stack