What’s Vulnerable › Vulnerabilities
CVE-2025-48917: EU Cookie Compliance (GDPR Compliance) - Moderately critical - Cross Site Scripting - SA-CONTRIB-2025-072
- Severity: medium (CVSS 5.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-13 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal EU Cookie Compliance (GDPR Compliance) allows Cross-Site Scripting (XSS).This issue affects EU Cookie Compliance (GDPR Compliance): from 0.0.0 before 1.26.0.
Affected products
- Drupal EU Cookie Compliance (GDPR Compliance): before 8.x-1.26.0 — fixed in 8.x-1.26.0
How to fix
Upgrade to a fixed version: Drupal EU Cookie Compliance (GDPR Compliance) 8.x-1.26.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-48917 or the next vulnerability affects your stack