What’s Vulnerable › Vulnerabilities
CVE-2025-48924: Apache Commons Lang, Apache Commons Lang: ClassUtils.getClass(...) can throw a StackOverflowError on very long inputs
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-11 · updated 2026-06-17
- Weakness: CWE-674
Description
Uncontrolled Recursion vulnerability in Apache Commons Lang. This issue affects Apache Commons Lang: Starting with commons-lang:commons-lang 2.0 to 2.6, and, from org.apache.commons:commons-lang3 3.0 before 3.18.0. The methods ClassUtils.getClass(...) can throw StackOverflowError on very long inputs. Because an Error is usually not handled by applications and libraries, a StackOverflowError could cause an application to stop. Users are recommended to upgrade to version 3.18.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache Commons Lang: from 2.0 before 2.6; from 3.0 before 3.18.0 — fixed in 2.6, 3.18.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Commons Lang 2.6, 3.18.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/bgv0lpswokgol11tloxnjfzdl7yrc1g1
- http://www.openwall.com/lists/oss-security/2025/07/11/1
- https://lists.debian.org/debian-lts-announce/2025/08/msg00000.html
- https://lists.debian.org/debian-lts-announce/2025/08/msg00026.html
- https://lists.debian.org/debian-lts-announce/2025/09/msg00032.html
- https://lists.debian.org/debian-lts-announce/2025/09/msg00036.html
Get alerted when CVE-2025-48924 or the next vulnerability affects your stack