What’s Vulnerable › Vulnerabilities
CVE-2025-48940: MyBB's upgrade component vulnerable to local file inclusion
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-02 · updated 2026-06-17
- Weakness: CWE-22
Description
MyBB is free and open source forum software. Prior to version 1.8.39, the upgrade component does not validate user input properly, which allows attackers to perform local file inclusion (LFI) via a specially crafted parameter value. In order to exploit the vulnerability, the installer must be unlocked (no `install/lock` file present) and the upgrade script must be accessible (by re-installing the forum via access to `install/index.php`; when the forum has not yet been installed; or the attacker is authenticated as a forum administrator). MyBB 1.8.39 resolves this issue.
Affected products
- mybb: before 1.8.39 — fixed in 1.8.39
How to fix
Upgrade to a fixed version: mybb 1.8.39. Check the vendor advisory for mitigations.
References
- https://github.com/mybb/mybb/commit/6e6cfbd524d9101b51e1278ecf520479b64b0f00
- https://github.com/mybb/mybb/security/advisories/GHSA-q4jv-xwjx-37cp
- https://mybb.com/versions/1.8.39
Get alerted when CVE-2025-48940 or the next vulnerability affects your stack