What’s Vulnerable › Vulnerabilities
CVE-2025-48942: vLLM DOS: Remotely kill vllm over http with invalid JSON schema
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-30 · updated 2026-06-17
- Weakness: CWE-248
Description
vLLM is an inference and serving engine for large language models (LLMs). In versions 0.8.0 up to but excluding 0.9.0, hitting the /v1/completions API with a invalid json_schema as a Guided Param kills the vllm server. This vulnerability is similar GHSA-9hcf-v7m4-6m2j/CVE-2025-48943, but for regex instead of a JSON schema. Version 0.9.0 fixes the issue.
Affected products
- vllm-project vllm: from 0.8.0 before 0.9.0 — fixed in 0.9.0
How to fix
Upgrade to a fixed version: vllm-project vllm 0.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/vllm-project/vllm/commit/08bf7840780980c7568c573c70a6a8db94fd45ff
- https://github.com/vllm-project/vllm/issues/17248
- https://github.com/vllm-project/vllm/pull/17623
- https://github.com/vllm-project/vllm/security/advisories/GHSA-6qc9-v4r8-22xg
Get alerted when CVE-2025-48942 or the next vulnerability affects your stack