What’s Vulnerable › Vulnerabilities
CVE-2025-48943: vLLM allows clients to crash the openai server with invalid regex
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-30 · updated 2026-06-17
- Weakness: CWE-248
Description
vLLM is an inference and serving engine for large language models (LLMs). Version 0.8.0 up to but excluding 0.9.0 have a Denial of Service (ReDoS) that causes the vLLM server to crash if an invalid regex was provided while using structured output. This vulnerability is similar to GHSA-6qc9-v4r8-22xg/CVE-2025-48942, but for regex instead of a JSON schema. Version 0.9.0 fixes the issue.
Affected products
- vllm-project vllm: from 0.8.0 before 0.9.0 — fixed in 0.9.0
How to fix
Upgrade to a fixed version: vllm-project vllm 0.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/vllm-project/vllm/commit/08bf7840780980c7568c573c70a6a8db94fd45ff
- https://github.com/vllm-project/vllm/issues/17313
- https://github.com/vllm-project/vllm/pull/17623
- https://github.com/vllm-project/vllm/security/advisories/GHSA-9hcf-v7m4-6m2j
Get alerted when CVE-2025-48943 or the next vulnerability affects your stack