What’s Vulnerable › Vulnerabilities
CVE-2025-48944: vLLM Tool Schema allows DoS via Malformed pattern and type Fields
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-30 · updated 2026-06-17
- Weakness: CWE-20
Description
vLLM is an inference and serving engine for large language models (LLMs). In version 0.8.0 up to but excluding 0.9.0, the vLLM backend used with the /v1/chat/completions OpenAPI endpoint fails to validate unexpected or malformed input in the "pattern" and "type" fields when the tools functionality is invoked. These inputs are not validated before being compiled or parsed, causing a crash of the inference worker with a single request. The worker will remain down until it is restarted. Version 0.9.0 fixes the issue.
Affected products
- vllm-project vllm: from 0.8.0 before 0.9.0 — fixed in 0.9.0
How to fix
Upgrade to a fixed version: vllm-project vllm 0.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/vllm-project/vllm/pull/17623
- https://github.com/vllm-project/vllm/security/advisories/GHSA-vrq3-r879-7m65
Get alerted when CVE-2025-48944 or the next vulnerability affects your stack