What’s Vulnerable › Vulnerabilities
CVE-2025-48947: NextJS-Auth0 SDK Vulnerable to CDN Caching of Session Cookies
- Severity: high (CVSS 7.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-04 · updated 2026-06-17
- Weakness: CWE-525
Description
The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. In Auth0 Next.js SDK versions 4.0.1 through 4.6.0, `__session` cookies set by auth0.middleware may be cached by CDNs due to missing Cache-Control headers. Three preconditions must be met in order for someone to be affected by the vulnerability: Applications using the NextJS-Auth0 SDK, versions between 4.0.1 to 4.6.0, applications using CDN or edge caching that caches responses with the Set-Cookie header, and if the Cache-Control header is not properly set for sensitive responses. Users should upgrade auth0/nextjs-auth0 to v4.6.1 to receive a patch.
Affected products
- auth0 nextjs-auth0: from 4.0.1, < 4.6.1
References
Get alerted when CVE-2025-48947 or the next vulnerability affects your stack