What’s Vulnerable › Vulnerabilities
CVE-2025-48949: Navidrome allows SQL Injection via role parameter
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-30 · updated 2026-06-17
- Weakness: CWE-89
Description
Navidrome is an open source web-based music collection server and streamer. Versions 0.55.0 through 0.55.2 have a vulnerability due to improper input validation on the `role` parameter within the API endpoint `/api/artist`. Attackers can exploit this flaw to inject arbitrary SQL queries, potentially gaining unauthorized access to the backend database and compromising sensitive user information. Version 0.56.0 contains a patch for the issue.
Affected products
- navidrome: from 0.55.0 before 0.56.0 — fixed in 0.56.0
How to fix
Upgrade to a fixed version: navidrome 0.56.0. Check the vendor advisory for mitigations.
References
- https://github.com/navidrome/navidrome/commit/b19d5f0d3e079639904cac95735228f445c798b6
- https://github.com/navidrome/navidrome/security/advisories/GHSA-5wgp-vjxm-3x2r
Get alerted when CVE-2025-48949 or the next vulnerability affects your stack