What’s Vulnerable › Vulnerabilities
CVE-2025-48954: Discourse vulnerable to XSS via user-provided query parameter in oauth failure flow
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-25 · updated 2026-06-17
- Weakness: CWE-79
Description
Discourse is an open-source discussion platform. Versions prior to 3.5.0.beta6 are vulnerable to cross-site scripting when the content security policy isn't enabled when using social logins. Version 3.5.0.beta6 patches the issue. As a workaround, have the content security policy enabled.
Affected products
- discourse: before 3.5.0; 3.5.0-beta1, 3.5.0-beta2, 3.5.0-beta3, 3.5.0-beta4, 3.5.0-beta5 — fixed in 3.5.0
How to fix
Upgrade to a fixed version: discourse 3.5.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-48954 or the next vulnerability affects your stack