What’s Vulnerable › Vulnerabilities
CVE-2025-48956: vLLM API endpoints vulnerable to Denial of Service Attacks
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-21 · updated 2026-06-17
- Weakness: CWE-400
Description
vLLM is an inference and serving engine for large language models (LLMs). From 0.1.0 to before 0.10.1.1, a Denial of Service (DoS) vulnerability can be triggered by sending a single HTTP GET request with an extremely large header to an HTTP endpoint. This results in server memory exhaustion, potentially leading to a crash or unresponsiveness. The attack does not require authentication, making it exploitable by any remote user. This vulnerability is fixed in 0.10.1.1.
Affected products
- vllm-project vllm: from 0.1.0 before 0.10.1.1 — fixed in 0.10.1.1
How to fix
Upgrade to a fixed version: vllm-project vllm 0.10.1.1. Check the vendor advisory for mitigations.
References
- https://github.com/vllm-project/vllm/commit/d8b736f913a59117803d6701521d2e4861701944
- https://github.com/vllm-project/vllm/pull/23267
- https://github.com/vllm-project/vllm/security/advisories/GHSA-rxc4-3w6r-4v47
Get alerted when CVE-2025-48956 or the next vulnerability affects your stack