What’s Vulnerable › Vulnerabilities
CVE-2025-48977: Apache Ignite: REST HTTP arbitrary file read vulnerability
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-28 · updated 2026-10-07
- Weakness: CWE-23
Description
Relative Path Traversal vulnerability in Apache Ignite REST API. Authenticated REST API users can read any file on the server with "cmd=log" command and a log path crafted in a certain way. This issue affects Apache Ignite: from 2.0.0 through 2.17.0. Users are recommended to upgrade to version 2.18.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache Ignite: from 2.0.0 before 2.18.0 — fixed in 2.18.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Ignite 2.18.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/hgct6918sowd8l58yjohryhpxx81t4n1
- http://www.openwall.com/lists/oss-security/2026/05/28/3
Get alerted when CVE-2025-48977 or the next vulnerability affects your stack