What’s Vulnerable › Vulnerabilities
CVE-2025-48985
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-07 · updated 2026-10-07
- Weakness: CWE-20
Description
A vulnerability in Vercel’s AI SDK has been fixed in versions 5.0.52, 5.1.0-beta.9, and 6.0.0-beta. This issue may have allowed users to bypass filetype whitelists when uploading files. All users are encouraged to upgrade. More details: https://vercel.com/changelog/cve-2025-48985-input-validation-bypass-on-ai-sdk
Affected products
- vercel ai: before 5.0.52; 5.1.0-beta0, 5.1.0-beta1, 5.1.0-beta2, 5.1.0-beta3, 5.1.0-beta4, 5.1.0-beta5 (+3) — fixed in 5.0.52
How to fix
Upgrade to a fixed version: vercel ai 5.0.52. Check the vendor advisory for mitigations.
References
- https://github.com/vercel/ai/commit/930399bb9839a8baf3d349614106d78268775eed
- https://vercel.com/changelog/cve-2025-48985-input-validation-bypass-on-ai-sdk
Get alerted when CVE-2025-48985 or the next vulnerability affects your stack