What’s Vulnerable › Vulnerabilities

CVE-2025-48989: Apache Tomcat: h2 DoS - Made You Reset

Description

Improper Resource Shutdown or Release vulnerability in Apache Tomcat made Tomcat vulnerable to the made you reset attack. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.9, from 10.1.0-M1 through 10.1.43 and from 9.0.0.M1 through 9.0.107. Older, EOL versions may also be affected. Users are recommended to upgrade to one of versions 11.0.10, 10.1.44 or 9.0.108 which fix the issue.

Affected products

How to fix

Upgrade to a fixed version: Apache Tomcat 10.1.44, 11.0.10, 9.0.108. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-48989 or the next vulnerability affects your stack