What’s Vulnerable › Vulnerabilities

CVE-2025-49113: RoundCube Webmail Deserialization of Untrusted Data Vulnerability

Description

Roundcube Webmail before 1.5.10 and 1.6.x before 1.6.11 allows remote code execution by authenticated users because the _from parameter in a URL is not validated in program/actions/settings/upload.php, leading to PHP Object Deserialization.

Affected products

How to fix

Upgrade to a fixed version: Roundcube Webmail 1.5.10, 1.6.11. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-49113 or the next vulnerability affects your stack