What’s Vulnerable › Vulnerabilities
CVE-2025-49125: Apache Tomcat: Security constraint bypass for pre/post-resources
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-16 · updated 2026-06-17
- Weakness: CWE-288
Description
Authentication Bypass Using an Alternate Path or Channel vulnerability in Apache Tomcat. When using PreResources or PostResources mounted other than at the root of the web application, it was possible to access those resources via an unexpected path. That path was likely not to be protected by the same security constraints as the expected path, allowing those security constraints to be bypassed. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.7, from 10.1.0-M1 through 10.1.41, from 9.0.0.M1 through 9.0.105. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.8, 10.1.42 or 9.0.106, which fix the issue.
Affected products
- Apache Tomcat: from 9.0.0 before 9.0.106; from 10.1.0 before 10.1.42; from 11.0.0 before 11.0.8 — fixed in 10.1.42, 11.0.8, 9.0.106
How to fix
Upgrade to a fixed version: Apache Tomcat 10.1.42, 11.0.8, 9.0.106. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/m66cytbfrty9k7dc4cg6tl1czhsnbywk
- http://www.openwall.com/lists/oss-security/2025/06/16/2
- https://lists.debian.org/debian-lts-announce/2025/07/msg00009.html
Get alerted when CVE-2025-49125 or the next vulnerability affects your stack