What’s Vulnerable › Vulnerabilities
CVE-2025-49126: Visionatrix Vulnerable to Reflected XSS Leading to Exfiltration of Secrets
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-23 · updated 2026-06-17
- Weakness: CWE-79
Description
Visionatrix is an AI Media processing tool using ComfyUI. In versions 1.5.0 to before 2.5.1, the /docs/flows endpoint is vulnerable to a Reflected XSS (Cross-Site Scripting) attack allowing full takeover of the application and exfiltration of secrets stored in the application. The implementation uses the get_swagger_ui_html function from FastAPI. This function does not encode or sanitize its arguments before using them to generate the HTML for the swagger documentation page and is not intended to be used with user-controlled arguments. Any user of this application can be targeted with a one-click attack that can takeover their session and all the secrets that may be contained within it. This issue has been patched in version 2.5.1.
Affected products
- Visionatrix: from 1.5.0, < 2.5.1
References
- https://github.com/Visionatrix/Visionatrix/commit/63aafe6e4d1bffe4bf69e73b6fdfc65c71a8f5b8
- https://github.com/Visionatrix/Visionatrix/security/advisories/GHSA-w36r-9jvx-q48v
Get alerted when CVE-2025-49126 or the next vulnerability affects your stack