What’s Vulnerable › Vulnerabilities
CVE-2025-49130: Laravel Translation Manager Vulnerable to Stored Cross-site Scripting
- Severity: medium (CVSS 6.0 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-09 · updated 2026-06-17
- Weakness: CWE-79
Description
Laravel Translation Manager is a package to manage Laravel translation files. Prior to version 0.6.8, the application is vulnerable to Cross-Site Scripting (XSS) attacks due to incorrect input validation and sanitization of user-input data. An attacker can inject arbitrary HTML code, including JavaScript scripts, into the page processed by the user's browser, allowing them to steal sensitive data, hijack user sessions, or conduct other malicious activities. Only authenticated users with access to the translation manager are impacted. The issue is fixed in version 0.6.8.
Affected products
- barryvdh laravel-translation-manager: before 0.6.8
References
- https://github.com/barryvdh/laravel-translation-manager/commit/527446ed419f90f2319675fc5211cb8f851d7a1f
- https://github.com/barryvdh/laravel-translation-manager/pull/475
- https://github.com/barryvdh/laravel-translation-manager/releases/tag/v0.6.8
- https://github.com/barryvdh/laravel-translation-manager/security/advisories/GHSA-j226-63j7-qrqh
Get alerted when CVE-2025-49130 or the next vulnerability affects your stack