What’s Vulnerable › Vulnerabilities
CVE-2025-49137: Hax CMS Stored Cross-Site Scripting vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-09 · updated 2026-06-17
- Weakness: CWE-79
Description
HAX CMS PHP allows users to manage their microsite universe with a PHP backend. Prior to version 11.0.0, the application does not sufficiently sanitize user input, allowing for the execution of arbitrary JavaScript code. The 'saveNode' and 'saveManifest' endpoints take user input and store it in the JSON schema for the site. This content is then rendered in the generated HAX site. Although the application does not allow users to supply a `script` tag, it does allow the use of other HTML tags to run JavaScript. Version 11.0.0 fixes the issue.
Affected products
- haxtheweb haxcms-nodejs: before 11.0.0 — fixed in 11.0.0
- haxtheweb haxcms-php: before 11.0.0 — fixed in 11.0.0
How to fix
Upgrade to a fixed version: haxtheweb haxcms-nodejs 11.0.0; haxtheweb haxcms-php 11.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/haxtheweb/haxcms-php/commit/0dd3e98fe2fadd0793b667d4af2aac230980e0f8
- https://github.com/haxtheweb/issues/security/advisories/GHSA-2vc4-3hx7-v7v7
- https://github.com/haxtheweb/issues/security/advisories/GHSA-2vc4-3hx7-v7v7
Get alerted when CVE-2025-49137 or the next vulnerability affects your stack