What’s Vulnerable › Vulnerabilities
CVE-2025-49139: @haxtheweb/haxcms-nodejs Iframe Phishing vulnerability
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-09 · updated 2026-06-17
- Weakness: CWE-1021
Description
HAX CMS PHP allows users to manage their microsite universe with a PHP backend. Prior to version 11.0.0, in the HAX site editor, users can create a website block to load another site in an iframe. The application allows users to supply a target URL in the website block. When the HAX site is visited, the client's browser will query the supplied URL. An authenticated attacker can create a HAX site with a website block pointing at an attacker-controlled server running Responder or a similar tool. The attacker can then conduct a phishing attack by convincing another user to visit their malicious HAX site to harvest credentials. Version 11.0.0 contains a patch for the issue.
Affected products
- haxtheweb haxcms-nodejs: before 11.0.0 — fixed in 11.0.0
- haxtheweb haxcms-php: before 11.0.0 — fixed in 11.0.0
How to fix
Upgrade to a fixed version: haxtheweb haxcms-nodejs 11.0.0; haxtheweb haxcms-php 11.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/haxtheweb/haxcms-nodejs/commit/5368eb9b278ca47cd9a83b8d3e6216375615b8f5
- https://github.com/haxtheweb/issues/security/advisories/GHSA-v3ph-2q5q-cg88
- https://github.com/haxtheweb/issues/security/advisories/GHSA-v3ph-2q5q-cg88
Get alerted when CVE-2025-49139 or the next vulnerability affects your stack