What’s Vulnerable › Vulnerabilities
CVE-2025-49140: Pion Interceptor's improper RTP padding handling allows remote crash for SFU users (DoS)
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-09 · updated 2026-06-17
- Weakness: CWE-770
Description
Pion Interceptor is a framework for building RTP/RTCP communication software. Versions v0.1.36 through v0.1.38 contain a bug in a RTP packet factory that can be exploited to trigger a panic with Pion based SFU via crafted RTP packets, This only affect users that use pion/interceptor. Users should upgrade to v0.1.39 or later, which validates that: `padLen > 0 && padLen <= payloadLength` and return error on overflow, avoiding panic. If upgrading is not possible, apply the patch from the pull request manually or drop packets whose P-bit is set but whose padLen is zero or larger than the remaining payload.
Affected products
- pion interceptor: from 0.1.36, < 0.1.39
References
- https://github.com/pion/interceptor/commit/fa5b35ea867389cec33a9c82fffbd459ca8958e5
- https://github.com/pion/interceptor/pull/338
- https://github.com/pion/interceptor/security/advisories/GHSA-f26w-gh5m-qq77
- https://github.com/pion/webrtc/issues/3148
Get alerted when CVE-2025-49140 or the next vulnerability affects your stack