What’s Vulnerable › Vulnerabilities
CVE-2025-49141: HaxCMS-PHP Command Injection Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-09 · updated 2026-06-17
- Weakness: CWE-78
Description
HAX CMS PHP allows users to manage their microsite universe with a PHP backend. Prior to version 11.0.3, the `gitImportSite` functionality obtains a URL string from a POST request and insufficiently validates user input. The `set_remote` function later passes this input into `proc_open`, yielding OS command injection. An authenticated attacker can craft a URL string that bypasses the validation checks employed by the `filter_var` and `strpos` functions in order to execute arbitrary OS commands on the backend server. The attacker can exfiltrate command output via an HTTP request. Version 11.0.3 contains a patch for the issue.
Affected products
- haxtheweb haxcms-nodejs: before 11.0.3 — fixed in 11.0.3
- haxtheweb haxcms-php: before 11.0.0 — fixed in 11.0.0
How to fix
Upgrade to a fixed version: haxtheweb haxcms-nodejs 11.0.3; haxtheweb haxcms-php 11.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/haxtheweb/haxcms-nodejs/commit/5131fea6b6be611db76a618f89bd2e164752e9b3
- https://github.com/haxtheweb/issues/security/advisories/GHSA-g4cf-pp4x-hqgw
- https://github.com/haxtheweb/issues/security/advisories/GHSA-g4cf-pp4x-hqgw
Get alerted when CVE-2025-49141 or the next vulnerability affects your stack