What’s Vulnerable › Vulnerabilities
CVE-2025-49217
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-17 · updated 2026-06-17
- Weakness: CWE-477
Description
An insecure deserialization operation in the Trend Micro Endpoint Encryption PolicyServer could lead to a pre-authentication remote code execution on affected installations. Note that this vulnerability is similar to CVE-2025-49213 but is in a different method.
Affected products
- Trend Micro, Inc. Trend Micro Endpoint Encryption Policy Server: before 6.0.0.4013 — fixed in 6.0.0.4013
How to fix
Upgrade to a fixed version: Trend Micro, Inc. Trend Micro Endpoint Encryption Policy Server 6.0.0.4013. Check the vendor advisory for mitigations.
References
- https://success.trendmicro.com/en-US/solution/KA-0019928
- https://www.zerodayinitiative.com/advisories/ZDI-25-374/
Get alerted when CVE-2025-49217 or the next vulnerability affects your stack