What’s Vulnerable › Vulnerabilities
CVE-2025-4922: Nomad Vulnerable To Incorrect ACL Policy Lookup Attached To A Job
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-06-11 · updated 2026-06-17
- Weakness: CWE-266
Description
Nomad Community and Nomad Enterprise (“Nomad”) prefix-based ACL policy lookup can lead to incorrect rule application and shadowing. This vulnerability, identified as CVE-2025-4922, is fixed in Nomad Community Edition 1.10.2 and Nomad Enterprise 1.10.2, 1.9.10, and 1.8.14.
Affected products
- HashiCorp Nomad Enterprise: from 1.4.0 before 1.8.14; from 1.4.0 before 1.10.2; from 1.9.0 before 1.9.10; from 1.10.0 before 1.10.2 — fixed in 1.10.2, 1.8.14, 1.9.10
How to fix
Upgrade to a fixed version: HashiCorp Nomad Enterprise 1.10.2, 1.8.14, 1.9.10. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-4922 or the next vulnerability affects your stack