What’s Vulnerable › Vulnerabilities
CVE-2025-4943: LA-Studio Element Kit for Elementor <= 1.5.2 - Authenticated (Contributor+) DOM-Based Stored Cross-Site Scripting via data-lakit-element-link Parameter
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-30 · updated 2026-06-17
- Weakness: CWE-79
Description
The LA-Studio Element Kit for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘data-lakit-element-link’ parameter in all versions up to, and including, 1.5.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- choijun LA-Studio Element Kit for Elementor: before 1.5.3 — fixed in 1.5.3
How to fix
Upgrade to a fixed version: choijun LA-Studio Element Kit for Elementor 1.5.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/lastudio-element-kit/trunk/assets/js/addons/wrapper-links.min.js
- https://plugins.trac.wordpress.org/changeset/3302784/
- https://wordpress.org/plugins/lastudio-element-kit/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/5c5822b9-7fd0-4c39-a298-70d0debcc136?source=cve
Get alerted when CVE-2025-4943 or the next vulnerability affects your stack