What’s Vulnerable › Vulnerabilities
CVE-2025-4951
- Severity: medium (CVSS 4.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-20 · updated 2026-06-17
- Weakness: CWE-79
Description
Editions of Rapid7 AppSpider Pro before version 7.5.018 is vulnerable to a stored cross-site scripting vulnerability in the "ScanName" field. Despite the application preventing the inclusion of special characters within the "ScanName" field, this could be bypassed by modifying the configuration file directly. This is fixed as of version 7.5.018
Affected products
- Rapid7 AppSpider Pro: before 7.5.018 — fixed in 7.5.018
How to fix
Upgrade to a fixed version: Rapid7 AppSpider Pro 7.5.018. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-4951 or the next vulnerability affects your stack