What’s Vulnerable › Vulnerabilities
CVE-2025-49531: Illustrator | Integer Overflow or Wraparound (CWE-190)
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-07-08 · updated 2026-06-17
- Weakness: CWE-190
Description
Illustrator versions 28.7.6, 29.5.1 and earlier are affected by an Integer Overflow or Wraparound vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Illustrator: from 28.0 before 28.7.8; from 29.0 before 29.6 — fixed in 28.7.8, 29.6
How to fix
Upgrade to a fixed version: Adobe Illustrator 28.7.8, 29.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-49531 or the next vulnerability affects your stack