What’s Vulnerable › Vulnerabilities

CVE-2025-49563: Illustrator | Out-of-bounds Write (CWE-787)

Description

Illustrator versions 28.7.8, 29.6.1 and earlier are affected by an out-of-bounds write vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.

Affected products

How to fix

Upgrade to a fixed version: Adobe Illustrator 28.7.9, 29.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-49563 or the next vulnerability affects your stack