What’s Vulnerable › Vulnerabilities
CVE-2025-49567: Illustrator | NULL Pointer Dereference (CWE-476)
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-12 · updated 2026-06-17
- Weakness: CWE-476
Description
Illustrator versions 28.7.8, 29.6.1 and earlier are affected by a NULL Pointer Dereference vulnerability that could lead to application denial-of-service. An attacker could exploit this vulnerability to crash the application, causing a disruption in service. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Illustrator: from 28.0 before 28.7.9; from 29.0 before 29.7 — fixed in 28.7.9, 29.7
How to fix
Upgrade to a fixed version: Adobe Illustrator 28.7.9, 29.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-49567 or the next vulnerability affects your stack