What’s Vulnerable › Vulnerabilities
CVE-2025-49570: Photoshop Desktop | Out-of-bounds Write (CWE-787)
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-08-12 · updated 2026-06-17
- Weakness: CWE-787
Description
Photoshop Desktop versions 25.12.3, 26.8 and earlier are affected by an out-of-bounds write vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Photoshop: from 25.0 before 25.12.4; from 26.0 before 26.9 — fixed in 25.12.4, 26.9
How to fix
Upgrade to a fixed version: Adobe Photoshop 25.12.4, 26.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-49570 or the next vulnerability affects your stack