What’s Vulnerable › Vulnerabilities
CVE-2025-49577: Citizen allows stored XSS in preference menu headings
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-12 · updated 2026-06-17
- Weakness: CWE-79
Description
Citizen is a MediaWiki skin that makes extensions part of the cohesive experience. Various preferences messages are inserted into raw HTML, allowing anybody who can edit those messages to insert arbitrary HTML into the DOM. This vulnerability is fixed in 3.3.1.
Affected products
- StarCitizenTools mediawiki-skins-Citizen: before 3.3.1 — fixed in 3.3.1
How to fix
Upgrade to a fixed version: StarCitizenTools mediawiki-skins-Citizen 3.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/StarCitizenTools/mediawiki-skins-Citizen/commit/93c36ac778397e0e7c46cf7adb1e5d848265f1bd
- https://github.com/StarCitizenTools/mediawiki-skins-Citizen/commit/a741639085d70c22a9f49890542a142a223bf981
- https://github.com/StarCitizenTools/mediawiki-skins-Citizen/security/advisories/GHSA-jwr7-992g-68mh
Get alerted when CVE-2025-49577 or the next vulnerability affects your stack