What’s Vulnerable › Vulnerabilities
CVE-2025-49580: XWiki allows privilege escalation through link refactoring
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-13 · updated 2026-06-17
- Weakness: CWE-266
Description
XWiki is a generic wiki platform. From 8.2 and 7.4.5 until 17.1.0-rc-1, 16.10.4, and 16.4.7, pages can gain script or programming rights when they contain a link and the target of the link is renamed or moved. This might lead to execution of scripts contained in xobjects that should have never been executed. This vulnerability is fixed in 17.1.0-rc-1, 16.10.4, and 16.4.7.
Affected products
- xwiki-platform: from 7.4.5 before 16.4.7; from 16.5.0 before 16.10.4; from 17.0.0 before 17.1.0 — fixed in 16.10.4, 16.4.7, 17.1.0
How to fix
Upgrade to a fixed version: xwiki-platform 16.10.4, 16.4.7, 17.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/xwiki/xwiki-platform/commit/ab209acd780da69a4c5ff77ff011efd698273cec
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-jm43-hrq7-r7w6
- https://jira.xwiki.org/browse/XWIKI-22836
Get alerted when CVE-2025-49580 or the next vulnerability affects your stack