What’s Vulnerable › Vulnerabilities
CVE-2025-49585: XWiki does not require right warnings for XClass definitions
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-06-13 · updated 2026-06-17
- Weakness: CWE-357
Description
XWiki is a generic wiki platform. In versions before 15.10.16, 16.0.0-rc-1 through 16.4.6, and 16.5.0-rc-1 through 16.10.1, when an attacker without script or programming right creates an XClass definition in XWiki (requires edit right), and that same document is later edited by a user with script, admin, or programming right, malicious code could be executed with the rights of the editing user without prior warning. In particular, this concerns custom display code, the script of computed properties and queries in database list properties. Note that warnings before editing documents with dangerous properties have only been introduced in XWiki 15.9, before that version, this was a known issue and the advice was simply to be careful. This has been patched in XWiki 16.10.2, 16.4.7 and 15.10.16 by adding an analysis for the respective XClass properties.
Affected products
- xwiki-platform: before 15.10.16; from 16.0.0 before 16.4.7; from 16.5.0 before 16.10.2 — fixed in 15.10.16, 16.10.2, 16.4.7
How to fix
Upgrade to a fixed version: xwiki-platform 15.10.16, 16.10.2, 16.4.7. Check the vendor advisory for mitigations.
References
- https://github.com/xwiki/xwiki-platform/commit/385bde985cdb61ebf315d30c0b144b6d2e2c2d45
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-59w6-r9hm-439h
- https://jira.xwiki.org/browse/XWIKI-22476
Get alerted when CVE-2025-49585 or the next vulnerability affects your stack